Back to overview
Degraded
Some subscribers may have issues creating new listings
Nov 19 at 01:08am EST
Affected services
Add & Edit Listings
Resolved
Nov 19 at 10:34am EST
We identified and have resolved the issue with Tax Autofill in Listing Management.
Affected services
Created
Nov 19 at 01:08am EST
Tax Record Autofill is unavailable in Listing Management.
Affected services