Back to overview
Downtime

Nestfully is currently unavailable

Nov 24, 2024 at 10:23pm UTC
Affected services
Nestfully

Resolved
Nov 25, 2024 at 4:23am UTC

Nestfully service has been restored.

Created
Nov 24, 2024 at 10:23pm UTC

Nestfully is currently unavailable