Back to overview
Degraded
Ring Central Inbound Calls may not go through
Jan 22 at 03:00pm EST
Affected services
Phone Support
Resolved
Jan 23 at 08:16am EST
This was resolved as of 8:00 AM EST
Affected services
Created
Jan 22 at 03:00pm EST
Ring Central Inbound Support Calls may not go through
Affected services