Back to overview
Downtime

Nestfully.com website only is currently unavailable

Jan 24, 2025 at 12:43am UTC
Affected services
Nestfully

Resolved
Jan 24, 2025 at 1:27am UTC

Nestfully service is restored.

Created
Jan 24, 2025 at 12:43am UTC

Nestfully.com is currently unavailable