Back to overview
Degraded
Report a Violation and Support Links Currently Unavailable
Jun 16 at 10:29am EDT
Affected services
Account & Settings
Resolved
Jun 16 at 10:44am EDT
Report a Violation and Support Links have been restored.
Affected services
Created
Jun 16 at 10:29am EDT
The report a violation (bullseye) option on Bright listings and public records, Submit A Case link under My Support, and links to register for association training courses are currently unavailable. Our team is aware and working to resolve this issue as quickly as possible. You can report violations by emailing the necessary information to AccuracyandPolicy@BrightMLS.com.
Affected services